Uploaded image for project: 'CernVM'
  1. CernVM
  2. CVM-1953

Swissknife upload command occasionally segfaults

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Not a Bug
    • Affects Version/s: None
    • Fix Version/s: CernVM-FS 2.8
    • Component/s: CVMFS
    • Labels:
      None
    • Platforms:
      ANY
    • Development:

      Description

      As reported by Enrico, every now and then the following error appears

      cvmfs_swissknife: /home/sftnight/jenkins/workspace/CvmfsFullBuildDocker/CVMFS_BUILD_ARCH/docker-x86_64/CVMFS_BUILD_PLATFORM/cc7/build/BUILD/cvmfs-2.7.1/cvmfs/ingestion/task.h:83: void TubeConsumerGroup<ItemT>::Spawn() [with ItemT = BlockItem]: Assertion `retval == 0' failed.
      /usr/bin/cvmfs_server: line 7358:  2607 Aborted                 $user_shell "$(__swissknife_cmd) upload -r ${upstream}       -i $snapshotting_tmp                                       -o .cvmfs_is_snapshotting"
      cvmfs_swissknife: /home/sftnight/jenkins/workspace/CvmfsFullBuildDocker/CVMFS_BUILD_ARCH/docker-x86_64/CVMFS_BUILD_PLATFORM/cc7/build/BUILD/cvmfs-2.7.1/cvmfs/ingestion/task.h:83: void TubeConsumerGroup<ItemT>::Spawn() [with ItemT = BlockItem]: Assertion `retval == 0' failed.
      /usr/bin/cvmfs_server: line 7318:  2648 Aborted                 $user_shell "$(__swissknife_cmd) upload -r ${upstream}       -i $snapshotting_tmp                                       -o .cvmfs_is_snapshotting"
      

        Attachments

          Activity

            People

            Assignee:
            jblomer Jakob Blomer
            Reporter:
            jblomer Jakob Blomer
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: