Uploaded image for project: 'ROOT'
  1. ROOT
  2. ROOT-10687

ROOT prompt not working properly

    XMLWordPrintable

Details

    • Bug
    • Status: Open (View Workflow)
    • Low
    • Resolution: Unresolved
    • master
    • None
    • Core Libraries

    Description

      Hello,

       

      ROOT prompt does not seem to work properly. I don't see any "root [] " and tabcompletion aslo does not work. However, e.g, ((TRint*)gROOT->GetApplication())->GetPrompt() gives correctly (char *) "root [1] ". I.e. it looks like this

       

      $ root 
       ------------------------------------------------------------------
       | Welcome to ROOT 6.21/01 https://root.cern |
       | (c) 1995-2019, The ROOT Team; conception: R. Brun, F. Rademakers |
       | Built for linuxx8664gcc on Apr 11 2020, 14:32:00 |
       | From heads/master@3398f6db |
       | Try '.help', '.demo', '.license', '.credits', '.quit'/'.q' |
       ------------------------------------------------------------------
      ((TRint*)gROOT->GetApplication())->GetPrompt()
      (char *) "root [1] "
      

       

       

      It may be reproduced, e.g., for master or "conda install -c conda-forge root" (but I observe it already for some time). I'm not sure what the source of the problem is...

      Cheers,

      Jiri

       

      Attachments

        Activity

          People

            axel Axel Naumann
            jprochaz Jiri Prochazka
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated: