Uploaded image for project: 'ROOT'
  1. ROOT
  2. ROOT-5468

TLegend marker does not match TGraph marker

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Closed (View Workflow)
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: 5.34/00
    • Fix Version/s: None
    • Component/s: Graphics
    • Labels:
      None
    • Environment:

      Linux

      Description

      The marker/error line shown in the legend for a TGraph doesn't seem to match the marker/error line shown on the actual graph. See attached example, where I see a few differences:

      1. The line color in the legend doesn't match the graph
      2. The line width in the legend doesn't match the graph
      3. The end caps in the graph aren't shown in the legend
      4. The line in the legend passes through the marker, but is hidden in the graph

      The problem appears on-screen and in eps, png and pdf formats

        Attachments

        1. foo.png
          7 kB
        2. legend_bug.C
          0.7 kB
        3. screenshot_f207cd6.png
          screenshot_f207cd6.png
          8 kB
        4. Screen Shot 2017-01-16 at 11.10.51.png
          Screen Shot 2017-01-16 at 11.10.51.png
          75 kB

          Activity

            People

            Assignee:
            couet Olivier Couet
            Reporter:
            58014b51c1a86abcd84b Philip Rodrigues
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              PlannedEnd:
              PlannedStart:
              Actual Start:
              Actual End: