Uploaded image for project: 'ROOT'
  1. ROOT
  2. ROOT-8345

CMake: Triple CUDA+BLAS search

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 6.08/00
    • Labels:
      None
    • Environment:

      Ubuntu 14.04
      $ cmake --version
      cmake version 3.5.2

      Description

      I get the CUDA+BLAS search three times in a row:

      CUDA_TOOLKIT_ROOT_DIR not found or specified
      -- Could NOT find CUDA (missing:  CUDA_TOOLKIT_ROOT_DIR CUDA_NVCC_EXECUTABLE CUDA_INCLUDE_DIRS CUDA_CUDART_LIBRARY) 
      -- A library with BLAS API found.
      CUDA_TOOLKIT_ROOT_DIR not found or specified
      -- Could NOT find CUDA (missing:  CUDA_TOOLKIT_ROOT_DIR CUDA_NVCC_EXECUTABLE CUDA_INCLUDE_DIRS CUDA_CUDART_LIBRARY) 
      -- A library with BLAS API found.
      CUDA_TOOLKIT_ROOT_DIR not found or specified
      -- Could NOT find CUDA (missing:  CUDA_TOOLKIT_ROOT_DIR CUDA_NVCC_EXECUTABLE CUDA_INCLUDE_DIRS CUDA_CUDART_LIBRARY) 
      -- A library with BLAS API found.

      That's verbose and seemingly unnecessary. Let me know if you need more info.

        Attachments

          Activity

            People

            Assignee:
            mato Pere Mato Vila
            Reporter:
            axel Axel Naumann
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Actual End: