Uploaded image for project: 'SPI'
  1. SPI
  2. SPI-1026

Numpy broken in Ubuntu LCG views

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: High
    • Resolution: Fixed
    • Component/s: None
    • Labels:
      None
    • Environment:

      x86_64-ubuntu1604-gcc54-dbg

    • Development:

      Description

      Hello!

      Trying to use numpy on ubuntu, I get the following error. The same for slc6-gcc62 seems to work fine.

      ~$ source /cvmfs/sft.cern.ch/lcg/views/LCG_92/x86_64-ubuntu1604-gcc54-opt/setup.sh
      bash: /cvmfs/sft.cern.ch/lcg/views/LCG_92/x86_64-ubuntu1604-gcc54-opt/setup.sh: No such file or directory
      ~$ source /cvmfs/sft.cern.ch/lcg/views/LCG_92/x86_64-ubuntu1604-gcc54-dbg/setup.sh
      ~$ python
      Python 2.7.13 (default, Dec 16 2017, 16:08:09)
      [GCC 5.4.0 20160609] on linux2
      Type "help", "copyright", "credits" or "license" for more information.
      >>> import numpy
      Traceback (most recent call last):
        File "<stdin>", line 1, in <module>
        File "/cvmfs/sft.cern.ch/lcg/views/LCG_92/x86_64-ubuntu1604-gcc54-dbg/lib/python2.7/site-packages/numpy/_init_.py", line 142, in <module>
          from . import add_newdocs
        File "/cvmfs/sft.cern.ch/lcg/views/LCG_92/x86_64-ubuntu1604-gcc54-dbg/lib/python2.7/site-packages/numpy/add_newdocs.py", line 13, in <module>
          from numpy.lib import add_newdoc
        File "/cvmfs/sft.cern.ch/lcg/views/LCG_92/x86_64-ubuntu1604-gcc54-dbg/lib/python2.7/site-packages/numpy/lib/_init_.py", line 8, in <module>
          from .type_check import *
        File "/cvmfs/sft.cern.ch/lcg/views/LCG_92/x86_64-ubuntu1604-gcc54-dbg/lib/python2.7/site-packages/numpy/lib/type_check.py", line 11, in <module>
          import numpy.core.numeric as _nx
        File "/cvmfs/sft.cern.ch/lcg/views/LCG_92/x86_64-ubuntu1604-gcc54-dbg/lib/python2.7/site-packages/numpy/core/_init_.py", line 26, in <module>
          raise ImportError(msg)
      ImportError:
      Importing the multiarray numpy extension module failed.  Most
      likely you are trying to import a failed build of numpy.
      If you're working with a numpy git repo, try `git clean -xdf` (removes all
      files not under version control).  Otherwise reinstall numpy.

      Original error was: libcblas.so.3: cannot open shared object file: No such file or directory

      >>>

        Attachments

          Activity

            People

            • Assignee:
              pmendez Patricia Mendez Lorenzo
              Reporter:
              vavolkl Valentin Volkl
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                PlannedEnd:
                PlannedStart: